
Configuring version control system for AB Industrial 
programming Controllers using RSMACC Archive module, 
RSMACC Verification modules and RSMaintenanceLogiX500 
and RSMaintenanceLogiX5 programming software 
packages.                                                                       RSMACC (Rockwell Software© Maintenance Automation Control Center) 2003. 

                                 Credits: Peter Tiagunov LeanMES©, Free Academic License.

The purpose of this document to explain how to setup a particular AB Controller (PLC or SLC) to track the 
logic changes that will take place in that controller program during a prolonged period of time.

The system consist of the following components (fig.1):

1. The Industrial AB Controller (Device).
2. The Communication gateways and software (RSLinx).
3. Upload and Compare scheduler (RSMACC Verification Module).
4. Source Control database (RSMACC Archive Module).
5. Programming software for AB Industrial Controllers (RSMaintenanceLogiX500 and 

RSMaintenanceLogiX5).
6. Production files copies of the logic from the devices.

    Fig.1

Step 1. Uploading the logic that is currently running in the controller to a network directory, local  
directory  and the source control database. 

Start the RSMaintenanceLogiX500 for SLC type of controllers or RSMaintenanceLogiX5 for PLC types of 
controllers. In this example SLC type will be used. Start>Programs>Rockwell Software>RSLogix500 
English (fig.2)
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Click the Comm>System Comms…  (fig.3). Use navigation tree to get to the root (fig.4)

        Fig.3       Fig.4

Identify the required gateway (for example DG_2DC01) and click on it. In the right panel the list of all  
controllers that connected to this gateway will be displayed (fig.5). Select the required controller by clicking  
on it.  Click the “Upload” button to copy the logic from the controller into local file.

         Fig.5

In open window click the “Create New File” button. The controller logic will begin to upload to a file (fig.6)  
this process can take several minutes depends on communication and file size.

        Fig.6

When upload is complete click the “No” button to stay in Offline mode (fig.7).

         Fig.7



From the RSMaintenanceLogiX500 menu select File>Save As… and save the file to you’re a predefined 
network location for this particular controller for example W:\RSMACC\DG_2DC01\BT602503\ (fig.8)
Repeat operation again and save the same file into 

Repeat operation again and save the same file into your local directory, for example C:\My PLC Files (fig.10)
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From the RSMaintenanceLogiX500 menu select File>Source Control …> Add project to Source 
Database… . Navigate to a designate location for this file in the source control database (fig.10). Click the  
“OK” button to add the file to the database.

          Fig.10

Close currently open file in RSMaintenanceLogiX500.



From the RSMaintenanceLogiX500 menu select Tools>Source Control Utility… .

Navigate to the designated location in the tree for this controller in the database. Right click the file icon  
located in the right panel, in opened drop down menu click the “Check In” item (fig.11).
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Click the “OK” button to confirm Check In action. (Note! Local file will be removed) (fig.12).

     Fig.9

Right click the file icon located in the right panel, in opened drop down menu click the “Label” item 
(fig.14).

       Fig.14



In the Label field type “Master” , click the “OK” button. This operation will assign label Master to the version  
of the SLC logic file that just been created. (fig.15).

     Fig.15

Close the RCMACC Archive module. Close the RSMaintenanceLogiX500 programming software.
Step 1 is complete.

Step 2. Create the “Changes Detector” and “Master Reminder” schedules in RSMACC Verification module 
for the required controller using the files created in Step 1.

Start the RSMACC Verification module Editor. Start>Programs>Rockwell Software>RSMACC> 
Verification Editor… 
Select File>New Project… Create a new project, for example “TEST PROJECT”.
In the left panel right click the new project icon. From a drop down menu select Insert Group item.
Generic group will be created. Rename the group by using the right click on the group icon and select the  
Rename item. For example “DG” – this will represent the plant level group.

Create a new Gateway group. Use right click on the “DG” icon then Insert Group. Rename the Gateway 
group, for example “DG_2DC01”. Make sure that the name actually matching the real name (or network 
name) of the gateway computer. Note that the same RSLinx Gateway was used in Step 1. (Gateway is a 
computer located close to production devices (controllers) and where all the devices are connected to.)

In the right panel create a new schedule. Use right click anywhere in the right panel. Click the New 
Schedule item. Generic schedule will be created. Rename the schedule to “DG Changes Detector”. This 
schedule will run every night to detect changes in the controller logic. Note that this schedule is only  
detecting a new change by comparing the logic in the controller with the logic stored from the same 
controller during previous upload and compare process.
Create another schedule with the name “DG Master Reminder”. This schedule will run less often (for 
example every 3 days or once a week) and perform comparison between the latest version of the controller 
logic file and the Master file. After all the steps the “Verification Schedule Editor” window should look like  
this (fig.16).
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Add a new device (controller) to the gateway group, use right click on the gateway icon in the tree, select  
Insert Device. Next window will open (fig.17). Use navigation tree to locate the required gateway. Make 
sure that the gateway name matching the gateway group described in the previous paragraph. Select the  
device (controller) in the right panel and click the “OK” button (fig.17).

         Fig.17

The device will be added to the group. Use drag and drop windows function to add the device from the 
gateway group to “Change Detector” schedule. As soon as device dropped into the schedule the following 
window will open (fig.18). Since this is a “Change Detector” schedule, in the “Action/Interval” tab make  
sure that the “Action” field is set to “Upload and Compare”. Set the “Start Time” field to “12:00:00AM”. In 
this example use “Interval” option and set period value to 15 min (default).

    Fig.18

Click the ”Email Setup” tab. Select state(s) of the event that will trigger notification. Use the “Address Book”  
button to setup E-mail account of people who is going to be notified (fig.19).

      Fig.19



Click the “Event Files” tab. The most important settings are here. Make sure that the right files and sources  
will be used in every field. In this example the same device and files as described in step 1 will be used.

1. “Use RSLogix File format” box – checked
2. “Use device name as master file name” - unchecked
3. “Use device name as production file name” - unchecked
4. “Use device name as compare report file name” - checked
5. “Append compare data to existing report file” - unchecked (fig.20)

        Fig.20

To select the “Master File” click the “…” button next to the “Master File” field. The following window will open 
(fig.21). On the bottom of the “Select File” window click the “Source Control” tab. This operation will switch  
the source of the files from conventional method of accessing files in the folders located on local and 
networked drives to a method of accessing files in the database. If connection with the source control 
database not established use the login button to connect to the database. From the drop down list select  
the server where the source control database is located (fig.22).

Fig.22

     Fig.21

Navigate to the folder where the required file is stored. In this example the file “BT602503.RSS” is located 
in the subfolder of the “DG_2DC01” gateway folder (Refer to Step 1 if file is not available). (Notice the 
change in the color of the folders while operating in source control environment.) Select the file and click  
the “Open” button (fig.23). 

      Fig.23



To select the “Production File” click the “…” button next to the “Production File” field. In opened window 
navigate to the folder where the production file is located. In this example the path for the file is  
W:\RSMACC\DG_2DC01\BT602503\BT602503.RSS (fig.24). (Notice that the “Source Control” tab is not 
available for the production files.) Click the “Open” button to insert the file path to the “Production File”  
field.

    Fig.24

Very Important! In order to run the RSMACC Verification editor as a service (without user logged in) the 
path for the “Production File” and “Report File” must to be changed to a network path! For example:

W:\RSMACC\DG_2DC01\BT602503\BT602503.RSS 
Change to:
\\DET2KFISWEB\DF_CE\PLC\RSMACC\DG_2DC01\BT602503\BT602503.RSS

Use the network path in the “Report File” field. In this example:

\\DET2KFISWEB\DF_CE\PLC\RSMACC\DG_2DC01\BT602503\RPTChanges

After all modifications the “Device Event” window should look like this: (fig.25).
 

 Fig.25



In the “Device Event” window (fig.26) click the “Compare” tab. Apply the following setting:

1. Program Files - “Compare All Files” - Checked. (This will tell compare utility to compare the 
logic structure for all currently existing files in the 
controller and the files in the last uploaded version of the 
logic. (Refer to RSLogix software for file structure of the 
controller memory).

2. Data File - “Compare No Files” - Checked. (This will tell compare utility to ignore 
comparison of the data values between the current 
controller logic and the last uploaded logic).

3. “Promote New Upload to Master Directory” – Checked. (If logic changes detected the new version of 
the logic file will be created in the source control database 
and “Production File” folder.) 

 

  Fig.26

Click the “OK” to finalize the settings for this device event.

After all the steps the “Verification Schedule Editor” window should look like this (fig.27).

   Fig.27

Use drag and drop windows function to add the device from the gateway group to “Master Reminder” 
schedule. As soon as device dropped into the schedule the following window will open (fig.28). Since this is  
a “Master Reminder” schedule, in the “Action/Interval” tab make sure that the “Action” field is set to  
“Compare Only”. Set the “Start Time” field to “12:05:00AM”. In this example use “Interval” option and set 
period value to 15 min (default).



Very Important! When setting up the “Start Time” in the “Device Event” window in the project with multiple  
schedules, make sure that the “Start Time” for any given event in one schedule is not overlapping with 
other event(s) in another schedule(s). Having overlapping events in two or more schedules will cause  
unpredictable behavior of the Verification service and RSLogix modules.

Carefully plan schedules prior to deployment!

In this example the “Start Time” is set to “12:05:00AM”, which allow 5 min interval for the device event in  
“Master Reminder” schedule to complete before the device event in the “Master Reminder” schedule will 
take place. Notice that the reoccurrence for both events set to 15 min (fig.28).
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Click the ”Email Setup” tab. Select the state(s) of event that will trigger notification. Use the “Address Book”  
button to setup E-mail account of people who is going to be notified. For example in the “Changes Detector”  
schedule set up the control engineer(s) E-mail account(s) only. In the “Master Reminder” schedule setup  
the 
control engineer(s) and manager(s) E-mail account(s) to notify them if changes in the controller logic are  
not confirmed. 

Click the “Event Files” tab. To select the “Master File” click the “…” button next to the “Master File” field. The  
following window will open (fig.29). On the bottom of the “Select File” window click the “Source Control”  
tab. Navigate to the folder where the required file is stored. In this example the file “BT602503.RSS” is 
located in the subfolder of the “DG_2DC01” gateway folder. Click the      button to select a specific version 
of the file in the source control database (fig.29). The following window will open (fig.30). Select “Use this  
Label” option and click the “Master” label (The label “Master” was created in Step 1 of this manual). Click  
the “OK” button.

     Fig.30

                            Fig.29



Use the network path for the “Production File” In this example:
\\DET2KFISWEB\DF_CE\PLC\RSMACC\DG_2DC01\BT602503\BT602503.RSS

Use the network path in the “Report File” field. In this example:
\\DET2KFISWEB\DF_CE\PLC\RSMACC\DG_2DC01\BT602503\RPTMaster

After all modifications the “Device Event” window should look like this: (fig.31). Note that the label “Master”  
is now indicated in the “Master File” field.

    Fig.31

In the “Device Event” window (fig.32) click the “Compare” tab. Apply the following setting:

1. Program Files - “Compare All Files” - Checked. 

2. Data File - “Compare No Files” - Checked. 

Note that the “Promote New Upload to Master Directory” option is not available since this device event is  
not performing any uploads. Click the “OK” button.

     Fig.32



Save the project. In the right panel of the “Verification Schedule Editor” use right click the device icon in the  
“Change Detector” schedule. In the opened menu select “Run Now” (fig.33). Observe the upload and 
comparison process (may take a while, depends on amount of used memory in the controller). If errors 
returned Check device event configuration, perform Step 1 for this device again if necessary. Repeat the 
“Run Now” operation until success.
 

    Fig.33

Perform “Run Now” operation for the device event in the “Master Reminder” schedule as well.
Upon successful execution check both boxes next to the schedules names and test project in automatic  
mode (fig.34)

   Fig.34

Setup an additional devices using this manual. 



Appendix A Dual schedule model to track changes compare to previous and master versions.

Appendix B SQL2000 Query to retrieve RSMACC event statistic.
SELECT DateTimeOccured, Message 
from dbo.tblActiveEventsLog 
WHERE [Message] LIKE '%Scheduled Event Finished at%on 09/30/03%Event: Upload & Compare%' 
ORDER BY DateTimeOccured DESC 
 
-- Differences Only --------------------------------------------- 
SELECT TOP 100 PERCENT  
DateOccured = Convert(Varchar(12),DateTimeOccured,101),  
[Message] 
FROM dbo.tblActiveEventsLog 
WHERE --DateTimeOccured > '2003-09-28'  
Message LIKE '%Scheduled Event Finished at% on 09/30/03%' 
AND Message LIKE '%Differences Found!%' 
ORDER BY [Message] DESC 
 
-- No Differences ------------------------------------------------ 
SELECT TOP 100 PERCENT  
DateOccured = Convert(Varchar(12),DateTimeOccured,101),  
[Message] 
FROM dbo.tblActiveEventsLog 
WHERE --DateTimeOccured > '2003-09-28'  
Message LIKE '%Scheduled Event Finished at% on 09/30/03%' 
AND Message LIKE '%No Difference%' 
ORDER BY [Message] DESC 
 
 
PRINT 'RSMACC Upload&Compare Events Statistics for Oct 2003' 
PRINT '--------------------------------------------------------------------------' 
PRINT '' 
SELECT TOP 100 PERCENT 
[Differences]  =ISNULL(SUM(CASE WHEN  

[Message]LIKE '%Status:  Differences Found!%' THEN 1 END),0), 
[NoDifferences] =ISNULL(SUM(CASE WHEN  

[Message]LIKE '%Status:  No Difference%' THEN 1 END),0), 
[Failed] =ISNULL(SUM(CASE WHEN  

[Message]LIKE '%Status:  FAIL%'THEN 1 END),0), 
[Comm Error] =ISNULL(SUM(CASE WHEN  

[Message]LIKE '%Status:  Error%' or  
[Message]LIKE '%Status:  Cannot connect%' THEN 1 END),0), 

[Other] =ISNULL(SUM(CASE WHEN  
[Message]NOT LIKE '%Status:  Differences Found!%' AND 
[Message]NOT LIKE '%Status:  No Difference%' AND 
[Message]NOT LIKE '%Status:  FAIL%' AND 
[Message]NOT LIKE '%Status:  Error%' AND 
[Message]NOT LIKE '%Status:  Cannot connect%' THEN 1 END),0), 

[Total Events] =ISNULL(SUM(CASE WHEN  
 

[Message]LIKE '%' THEN 1 END),0) 
FROM dbo.tblActiveEventsLog 
WHERE [Message] LIKE '%Scheduled Event Finished at%on 10/__/03%Event: Upload & Compare%'



Appendix C Network Integration and device access scenarios.
Capability to access devices from both; Plant and Office networks, securely.


